This is no longer required as the function has been added as of 5.3.4.